Blank displays on Energy Monitors

For the Energy Monitor, ESP, and other monitors

Blank displays on Energy Monitors

Postby Coulomb on Thu Sep 23, 2010 7:35 pm

For some reason the older Energy Monitors don't like to start up when
power is applied. This may be due to aging on an electrolytic
capacitor, but that's just a guess.

If the unit are going to work at all, power must be applied quickly
without jitter as happens when a fuse is juggled a little into the fuse
holder. A better way is to use an on/off switch, or male/female spade
lugs that can quickly be connected.

You may have to try several times to get the familiar Start menu in the
display. We have one report that indicates the unit will start after
about 2 minutes. Strange behavior!

Once started, however, the unit operates normally.
Coulomb
Site Admin
 
Posts: 1174
Joined: Sat Jun 06, 2009 5:11 pm

Re: Blank displays on Energy Monitors

Postby MattRaj on Wed Aug 24, 2011 3:52 pm

Thanks for leaving this post up. I have this problem now. I had the batteries disconnected for a week, and I can now not get the screen to come back alive. Per your post, I paid careful attention to avoid "jitter". I made deliberate connections, waited 2 minutes. However, still no indication from the ESP. Could it be something else?

Thanks
Matt
MattRaj
 
Posts: 4
Joined: Tue Aug 16, 2011 12:02 am

Re: Blank displays on Energy Monitors

Postby Coulomb on Wed Aug 24, 2011 8:14 pm

Sorry, the ESP has a different problem, that isn't repairable. The menu system for the unit was stored in an internal RAM chip that contained a battery for backup when power was not present.

That battery had a guaranteed operational life of 10 years. Most have lasted about 20 years.

The chips are as obsolete as the original PC so there is no replacement possible.

We are working on a new monitor that will be better and less expensive that the ESP was.
Coulomb
Site Admin
 
Posts: 1174
Joined: Sat Jun 06, 2009 5:11 pm

Re: Blank displays on Energy Monitors

Postby MattRaj on Sun Aug 28, 2011 1:12 pm

Coulomb,
Sounds like my ESP has passed it's useful life. Do you have any guess-timates on the progress of a repalcement system? (Month or year of fielding? Will it be at any boat shows coming up?)
I have to determine if it will be worth wating for or moving on to something else.
Thanks,
Matt
MattRaj
 
Posts: 4
Joined: Tue Aug 16, 2011 12:02 am

Re: Blank displays on Energy Monitors

Postby Coulomb on Tue Aug 30, 2011 3:05 pm

Late this year or early next year.
Coulomb
Site Admin
 
Posts: 1174
Joined: Sat Jun 06, 2009 5:11 pm

Re: Blank displays on Energy Monitors

Postby bjrichar on Sun Dec 02, 2012 10:18 pm

Greetings,
Are you still willing to repair an EMON II-H1A that is showing a blank screen? I will try installing an off-on switch to avoid the "jiggle" when inserting a fuse. I disconnected the unit to install another wire on the positive distribution bar and the EMON didn't come back on. Any word on a replacement yet? Love the unit and the entire charging system.
Thanks, Byron
bjrichar
 
Posts: 19
Joined: Wed Dec 09, 2009 7:43 pm

Re: Blank displays on Energy Monitors

Postby Coulomb on Mon Dec 03, 2012 5:30 pm

Try the switch first. It's probably repairable, if you can't get it to work.
Coulomb
Site Admin
 
Posts: 1174
Joined: Sat Jun 06, 2009 5:11 pm


Return to Ample Power Monitors

Who is online

Users browsing this forum: No registered users and 1 guest

cron