Page 1 of 1

emon2 a , blank screen

PostPosted: Sat Jul 18, 2009 12:59 pm
by sailr69
I believe I had a back feed into the EMON2a, is it toast now?

Re: emon2 a , blank screen

PostPosted: Mon Jul 20, 2009 10:11 am
by Coulomb
There is a transient absorber on the power supply input with a series fuse resistor. If the resistor opened up then that would have saved the rest of the circuits, so the unit can be repaired.

If you do send it in, do not disconnect the terminal blocks from the cables to the Emon. Sorting them out again here is time consuming = $$. Carefully label all your wires at the terminal blocks. Be sure to remove all fuses before doing anything.

Re: emon2 a , blank screen

PostPosted: Mon Jul 20, 2009 10:26 am
by sailr69
I was told they do not repair these units, replacement only. ?? where would I send it?

Re: emon2 a , blank screen

PostPosted: Mon Jul 20, 2009 11:07 am
by Coulomb
We repair things we can still get parts for. If the processor in the unit got toasted, then it can't be repaired. Otherwise there is a good chance it can be done.

Send products for repair to:

Ample Power Company, LLC.
6315 Seaview Avenue, NW
Seattle, WA 98107

Include name, address, purchase information and contact phone or email.

Re: emon2 a , blank screen

PostPosted: Mon Aug 17, 2009 8:47 am
by sailr69
I sent in the unit for inspection, it has been recieved, now what? I have heard nothing so far about it

Re: emon2 a , blank screen

PostPosted: Mon Aug 17, 2009 8:47 am
by sailr69
I sent in the unit for inspection, it has been recieved, now what? I have heard nothing so far about it

Re: emon2 a , blank screen

PostPosted: Thu Aug 20, 2009 7:49 pm
by Coulomb
Our repair tech works part time, but he did come in today and fix what there was on the shelf. There was an Emon2 in the mix, so you should be contacted soon.