512

Isolator Eliminator

512

Postby capt_paul on Thu Aug 29, 2013 1:26 pm

Isolator is telling me It has an error with temp sensors (lt. 6sec on 6sec off) No sensor attached to the terminals. voltage across the terminals 1.3 ign off. 1.3 ign on shut down the system and started it back up, still error. help please. 512 in since2002
capt_paul
 
Posts: 5
Joined: Thu Aug 29, 2013 12:58 pm

Re: 512

Postby Coulomb on Thu Aug 29, 2013 3:47 pm

It make just be the temp. sensor. Disconnect the sensor wires and measure again at the terminals.
Coulomb
Site Admin
 
Posts: 1174
Joined: Sat Jun 06, 2009 5:11 pm

Re: 512

Postby capt_paul on Sat Aug 31, 2013 8:37 am

Temp sender is not attached. It was attached for about 9 years then this started so I detached it to check and there is still an error
capt_paul
 
Posts: 5
Joined: Thu Aug 29, 2013 12:58 pm

Re: 512

Postby Coulomb on Mon Sep 02, 2013 2:50 pm

Try tightening the end screws on terminal blocks. The very end screws make connection through standoffs to the inside. Over time and the environment, the contact between the standoff and the PCB can get a film on it.
Coulomb
Site Admin
 
Posts: 1174
Joined: Sat Jun 06, 2009 5:11 pm

Re: 512

Postby capt_paul on Wed Sep 04, 2013 7:27 am

Did that already. no change.
I tightened screws. Iunpluged temp sensors. I shut off all electricity to unit and re started. Error lt shows 6sec. on 6sec off
capt_paul
 
Posts: 5
Joined: Thu Aug 29, 2013 12:58 pm

Re: 512

Postby Coulomb on Wed Sep 04, 2013 3:01 pm

OK, there's some internal problem. It may be repairable.

Repair costs are usually $75 to $100.

Send products for repair to:
Ample Power Company, LLC.
6315 Seaview Avenue, NW
Seattle, WA 98107
Coulomb
Site Admin
 
Posts: 1174
Joined: Sat Jun 06, 2009 5:11 pm

Re: 512

Postby capt_paul on Thu Sep 05, 2013 7:26 am

Meanwhile, do you still have the field replacement module ( I assume that is what I need) available? Or do I need the whole unit to replace while I send this one for repairs?
capt_paul
 
Posts: 5
Joined: Thu Aug 29, 2013 12:58 pm

Re: 512

Postby Coulomb on Thu Sep 05, 2013 10:46 am

I'm not familiar with a field replacement module. Send in the whole unit with the terminal block PCB attached.
Coulomb
Site Admin
 
Posts: 1174
Joined: Sat Jun 06, 2009 5:11 pm

Re: 512

Postby capt_paul on Mon Sep 16, 2013 8:47 am

Ok 512 is no more. we had a good wake for it with plenty of alcohol involved while it it was placed in its final resting place. I will miss it. it gave many good years of service and it probably died of a minor thing that could have been corrected. But! We go on now with a replacement that has to be learned all over and I still have not the confidence in this new thing as I did my old faithful. Gone but not forgotten. RIP
capt_paul
 
Posts: 5
Joined: Thu Aug 29, 2013 12:58 pm

Re: 512

Postby Coulomb on Mon Sep 16, 2013 11:03 am

RIP Eliminator.
Coulomb
Site Admin
 
Posts: 1174
Joined: Sat Jun 06, 2009 5:11 pm


Return to Eliminator

Who is online

Users browsing this forum: No registered users and 1 guest

cron