Page 1 of 1

Fuse blowing on sense line on SAR1

PostPosted: Fri May 23, 2014 12:49 pm
by dmain
I've had a SAR12 (serial #916) operating swimmingly with a 100A Model 1022 (serial#517) alternator since 1994.
After re-installing my battery this spring, the fuse in the sense line keeps blowing when connected to the battery.
Everything is physically the same as always.
Any ideas as to what I could be looking for to remedy this?

Re: Fuse blowing on sense line on SAR1

PostPosted: Fri May 23, 2014 4:07 pm
by Coulomb
There's a short circuit developed, but without testing the unit we can't predict where it might be.

Twenty years of service is a pretty good track record. You might consider upgrading the the SAR V3. We offer a $50 discount for upgrades.

Re: Fuse blowing on sense line on SAR1

PostPosted: Mon May 26, 2014 3:17 am
by dmain
Thanks
I had a feeling things might head in this direction. I'll be in touch.

Re: Fuse blowing on sense line on SAR1

PostPosted: Fri Jun 06, 2014 12:39 pm
by dmain
Good Afternoon

I received my SAR V3 this week. (Thanks Ruth) I'm preparing to swap out the old with the new using the existing wiring. Does this chart look OK?

NEW OLD
1 ===
2 2=7
3 1=6
4 1=2
5 2=10
6 1=10
7 ===
8 1=8
9 2=8
10 1=9
11 ===
12 2=9
13 NEW
14 1=4
15 2=5

Re Battery Type Selection : I have a Surrette 4D Type 12 HHG 185PM (185A). I'm guessing thick plate liquid?

Regarding Terminals 14, 15 : I have a switch for current limiting (9 HP diesel) and a keyed switch for equalization. Do you have recommendations for settings for each? Do I need to short P1 ?

Your input is greatly appreciated; I don't think I'm as smart as I was 20 yrs. ago when I wired up the first one!

Regards, Dave

Re: Fuse blowing on sense line on SAR1

PostPosted: Fri Jun 06, 2014 12:50 pm
by dmain
I forgot to ask if the snubber #1030 is still required.
There's no mention of it in the new literature.

Thanks again, Dave