Page 3 of 3

Re: NEXT-12P Charge problem

PostPosted: Tue Aug 16, 2011 9:02 am
by Wolfgang
Next 12P did its job last time out but charging went from 80 amps bulk charge to 6 amps absorption charge within 1.5 hours. Batteries showed only 87.5% full. I adjusted the absorption time from 58 munites to 62 minutes (1.234 volts). Will this keep the bulkcharge going longer or do I go the other way(50 Minutes)???

Re: NEXT-12P Charge problem

PostPosted: Wed Aug 17, 2011 11:42 pm
by Coulomb
It could be the batteries, or it could be the monitor. There's more info about monitor errors on the forum.

Re: NEXT-12P Charge problem

PostPosted: Tue Mar 27, 2012 7:56 pm
by glorious32
After about 2 years, I finally have gotten around to test the alternator as per Ample's direction. The result shows that if the house bank is down about 50 amp hours (from 540 amp) and the house voltage is at 12.18v the alternator puts out 13.2v. After allowing the shore charger to bring the house up to 13.2v, the alternator puts out 15.4v. Thanks for getting me back on board. Is it new regulator time?

Re: NEXT-12P Charge problem

PostPosted: Wed Mar 28, 2012 1:40 pm
by Coulomb
The regulator is not sensing the voltage from the battery.

It can be repaired. Charges run from $150 to $175.

Send products for repair to:
Ample Power Company, LLC.
6315 Seaview Avenue, NW
Seattle, WA 98107

Re: NEXT-12P Charge problem

PostPosted: Thu Mar 29, 2012 12:34 pm
by glorious32
Sounds good. Thank you.

Re: NEXT-12P Charge problem

PostPosted: Tue Apr 03, 2012 12:45 pm
by Coulomb
It does appear the regulator is not operating.

Send products for repair to:

Ample Power Company, LLC.
6315 Seaview Avenue, NW
Seattle, WA 98107

Include name, address, purchase information and contact phone or email.

Maximum cost to repair is $175.00.

Re: NEXT-12P Charge problem

PostPosted: Thu Dec 13, 2012 7:37 am
by DonH
I just purchased a 2006 Camano Troll in September 2012 and noticed on the trip back to home port that the house battery bank was not charging. I have a 12P Next Step Regulator SN: N15001. I have tried to run the "Troubleshooting" Table 10 measurements and I am ok until I turn on the ignition. When I do this the 15Amp fuse in the B+ line blows, several times. I have checked for shorts but cannot see anything out of order. The previous owner advised everything was ok at least until he replaced the 4 bank house batteries in mid summer....and he hadn't used the boat much after that. Any ideas where I go from here?

Re: NEXT-12P Charge problem

PostPosted: Thu Dec 13, 2012 6:03 pm
by Coulomb
There's a short somewhere. You can disconnect the field wire from the regulator. If the fuse still blows the problem is in the regulator. If not, perhaps the field is shorted in the alternator.

Re: NEXT-12P Charge problem

PostPosted: Tue Oct 28, 2014 11:13 pm
by PClark
I have had on-going issues over many months trying to get my second alternator (House circuit) to work properly. I have an externally regulated alternator with a Next step 12P serial number N12209 on it. All voltages and everything seem fine, connections have been triple checked. The only thing that seems odd is that the Field wire is battery voltage when connected to the alt, but only 5V when disconnected. Is this correct. Battery voltage is 12.3 volts so alternator should be charging heaps.

Peter

Re: NEXT-12P Charge problem

PostPosted: Sat Nov 01, 2014 7:30 am
by Coulomb
5V disconnected is normal. With 12.3 Volts on the alternator it appears the alternator is defective. Do the full field test.