Page 1 of 1

NEXT-12P bad field reading

PostPosted: Wed Apr 13, 2011 1:09 pm
by franck-gab
hello
The exact model that we have is a Next Step Alternator Regulator, NEXT-12P, and it's plugged in to one alternator and one house battery.

we did the exercise of the troubleshooting procedure as you recommend and here is our result:



ignition off ignition on engine running
paralle 0,7 0,7 0,8
on/off 0,0 13,08 13,04
ground 0,0 0,0 0,0
B+ 13,20 13,20 13,19
Field 0,0 0,0 0,0
Alt.gnd 0,0 0,0 0,0
Lock 0,0 0,0 0,0
Bat volt 13,9 13,20 13,20
T- 0,0 0,0 0,0
T+ 0,0 3,01 3,01


as you can see we have problem with the field when it's unplugged; we have 5.5 V but when we plug the field wire it goes to 0,0V and the current is 0,0 A

the state indicator indicate :Bulk Charge
The error indicator indicate: Bat.Volts disconnected. But it's connected properly and it have the right voltage to the regulator.
I think that the regulator is not working properly, is it that or it's the alternator?
Is it something that can be fixed or does it need to be remplaced?

Thank you
sea Angel

Re: NEXT-12P bad field reading

PostPosted: Fri Apr 15, 2011 11:29 am
by Coulomb
When the field terminal is disconnected from the alternator the output voltage goes to about 5.5 Volts because your voltmeter is high impedance and you're measuring leakage current.

More than likely an internal part has failed in the battery sensing circuit so that the processor reads no voltage from that circuit.

It is repairable.

Send products for repair to:
Ample Power Company, LLC.
6315 Seaview Avenue, NW
Seattle, WA 98107