Page 1 of 1

NextStep Regulator - Not Charging

PostPosted: Fri Jul 10, 2009 2:50 pm
by cambria43
Good Day,

I am the master of a Westerly Ocean 43, cruising out of New Zealand, and am presently in the area of Howe Sound, British Columbia, Canada.

The NextStep regulator was professionally installed in New Zealand and has performed flawlessly up until yesterday when, in running the auxiliary to charge batteries, and checking the digital battery monitoring system, I noticed that no charge being applied to batteries although, by engine note, it was evident that the alternator was "loading" the engine as if charging properly. In fact, it appeared that, with the NextStep enabled, there was a larger amperage drain on the batteries than with it disabled (approx. 8 - 9 amps).

The NextStep regulator is controlling a 100 amp high temperature duty rated alternator which, in turn, is servicing a house battery bank of approx. 660 amp-hours capacity together with an engine starting battery of approx. 600 CCA. In typical usage, the house bank is not permitted to fall below 80 - 100 amp-hours (12.40 volts) down from full charge before re-charging.

All inline fuses were checked as good and the Troubleshooting tests/multimeter measurements were taken and recorderd per the Guideline. The results of such tests are as follows:
A B C
Row 1 House Battery + 13.22 13.14 13.10
Row 2 PARALLEL Tab 0.05 0.05 0.04
Row 3 ON/OFF Tab -0.02 -0.02 -0.02
Row 4 GROUND Tab 2.30 9.86 10.12
Row 5 B+ Tab 0.50 0.04 0.00
Row 6 FIELD Tab 5.14 5.73 5.72
Row 7 ALT.GND Tab 0.02 -3.35 -3.34
Row 8 LOCK Tab 0.01 0.01 0.01
Row 9 BAT. VOLTS Tab 0.01 0.01 0.01
Row 10 T- (BLK) Tab 0.01 0.01 0.01
Row 11 T+ (RED) Tab 0.09 4.76 4.76
Row 12 ABS Tab 0.01 0.01 0.01
Row 13 LAMP Tab 0.00 0.00 0.00

Thank you for any assistance or guidance which you can offer in this regard. As you may appreciate, without battery charging capability at anchor, this cruising season will be significantly and adversely affected.

Best regards,
David Gardiner, Capt
S.V. CAMBRIA
Westerly Ocean 43
UK MCA SSR 123379

Re: NextStep Regulator - Not Charging

PostPosted: Fri Jul 10, 2009 3:22 pm
by Coulomb
The ground tab should read 0V. The ground wire must be open. The regulator may
be fried as a result.