No output to field

For issues involving the NS2 regulator.

No output to field

Postby Owen on Tue Jan 07, 2014 8:06 pm

I have an NS2 installed in my motorhome, connected to a 24 volt system. Recently I went for a trip and soon afterwards the alternator light came on and stayed on. I took the cover off the NS2 and found that terminal block 1 was a bit loose, so i unplugged it and plugged it back in. Problem solved, but a week later I noticed the alternator light flashing on and off so I stopped and did the same thing. The light went out but a few kilometres down the road it came back on and stayed on. The voltages at all the input terminals are as they should be, except there is no output to the alternator field. I removed the wires from Pins 1 and 2, and connected them momentarily. The alternator loaded up and the warning light went out. I also replaced the terminal block with the one from TB2, thinking that the problem may have been caused by looseness in the block itself, but it didn't fix the problem. It would seem that there is a fault in the NS2 circuitry, but I don't want to go and buy a new one without exploring all possibilities. Could you please advise what I should do next?

Regards
Owen Holcombe

www.paleriders.com.au
Owen
 
Posts: 2
Joined: Tue Jan 07, 2014 6:55 pm

Re: No output to field

Postby Coulomb on Tue Jan 07, 2014 10:52 pm

Ouch!

Loose connections are destructive especially when driving inductive load such as an alternator field. High voltage transients are produced, and with every momentary opening of the circuit.

It is likely at this point that the alternator field driver mosfets have been blown up.

There's a 'snubber' on the board to help mitigate transients. It transients are big enough and frequent enough the snubber may work so hard that copper traces on the PCB are burned open. Visual inspection will suffice for that.
Coulomb
Site Admin
 
Posts: 1174
Joined: Sat Jun 06, 2009 5:11 pm

Re: No output to field

Postby Owen on Wed Jan 08, 2014 6:04 am

Coulomb, there is no visible damage or burning on the PCB. Is there an agent in Australia I can send it to for inspection?
Owen
 
Posts: 2
Joined: Tue Jan 07, 2014 6:55 pm


Return to NS2 Regulators

Who is online

Users browsing this forum: No registered users and 1 guest

cron