17 Volts when batteries are fully charged

For issues involving the NS2 regulator.

17 Volts when batteries are fully charged

Postby Jelder on Mon Jan 26, 2015 3:42 pm

Once batteries are fully charged it is charging at 17 volts. There are no error lights and when this occurs the status indicator is showing 1/1 i.e. absorption charge. The batteries are ok ( i.e. not faulty) and I get the same charging voltage when connected to each one independently ( I have 2 200 amp hour AGM's). Absorption charge is set to 14 volts and float to 13.3 volts. Any suggestions are most welcome. Thanks James
Jelder
 
Posts: 3
Joined: Mon Jan 26, 2015 1:38 pm

Re: 17 Volts when batteries are fully charged

Postby Coulomb on Mon Jan 26, 2015 7:30 pm

What are the voltage readings at the NS2 terminal blocks?
Coulomb
Site Admin
 
Posts: 1174
Joined: Sat Jun 06, 2009 5:11 pm

Re: 17 Volts when batteries are fully charged

Postby Jelder on Mon Jan 26, 2015 8:17 pm

Good point - I'm away from the boat now and will have to check it next weekend. I did check it at the battery terminals and it was 17 volts. Sounds like your point is it could be a poor connection between the battery and the NS2 terminal blocks, although I'm surprised that it can push out a voltage higher than the absorbtion setting of 14 volts. Many thanks for the response. James
Jelder
 
Posts: 3
Joined: Mon Jan 26, 2015 1:38 pm

Re: 17 Volts when batteries are fully charged

Postby Jelder on Sun Feb 01, 2015 3:01 pm

Solved it. There was bad connection in a fuse holder on the voltage sensor wire that caused it to send only 6 volts to the regulator, even though the battery was fully charged. Apparently 6 volts isn't low enough to trigger an error light on the regulator, but will convince the regulator to tell the alternator to put in maximum voltage. Fixing the connection resolved the problem.
Jelder
 
Posts: 3
Joined: Mon Jan 26, 2015 1:38 pm

Re: 17 Volts when batteries are fully charged

Postby Coulomb on Sun Feb 01, 2015 4:14 pm

Great troubleshooting and thanks for the report back.

There's very little current in the sense line, so fuse holders tend to get a corrosive film on them over time which acts a resistor, dropping a voltage. Connections are always an issue in a marine environment, and a fuse holder is a poor connection to begin with.
Coulomb
Site Admin
 
Posts: 1174
Joined: Sat Jun 06, 2009 5:11 pm


Return to NS2 Regulators

Who is online

Users browsing this forum: No registered users and 1 guest

cron