NS2 Troubleshooting

For issues involving the NS2 regulator.

NS2 Troubleshooting

Postby allied on Thu Mar 31, 2016 7:24 am

My new NS2 regulator and newly rebuilt Ample alternator are not charging, so I ran the troubleshooting guide steps. The results:
Ig. Off Ig. On Eng. Running
B+ 12.60V 12.51V 12.51V
Field 9.84V 12.48V 12.48V
Alt. GND 0 0 0
House Batt. 12.62V 12.56V 12.56V
On/Off 18.3mv 12.31V 12.27V
T+ 0.516V 0.514V 0.512V
T- 0 0 0
Ground 0 0 0

Obvious issues with Field (Ignition Off) and T+

Awaiting your comments and suggestions.

John Frederick
713-882-0292
allied
 
Posts: 10
Joined: Fri Feb 19, 2016 5:35 pm

Re: NS2 Troubleshooting

Postby allied on Thu Mar 31, 2016 4:36 pm

I rechecked the voltages today and got similar readings...AND...I got a Voltage Runaway error...AND the alternator charged the house batteries all the way to absorption...BUT...the alternator did not charge the engine battery.
allied
 
Posts: 10
Joined: Fri Feb 19, 2016 5:35 pm

Re: NS2 Troubleshooting

Postby Coulomb on Fri Apr 01, 2016 11:22 am

You have multiple problems. The alternator should charge at a high rate with 9+ Volts on the field.

The T+ reading should be around 3 Volts. Do you have flashing green or red LEDs?
Coulomb
Site Admin
 
Posts: 1174
Joined: Sat Jun 06, 2009 5:11 pm

Re: NS2 Troubleshooting

Postby allied on Fri Apr 01, 2016 3:26 pm

My marine mechanic and I confirmed that the wiring was correct. We then ran the troubleshooting steps with following results.
Ign. Off Ign. On Eng. Running
1 B+ 12.33V 12.30V 12.30V
2 Field 0 0.26V 0
3 Alt. GND 0 0 0
4 House Batt 12.39V 12.27V 12.37V
5 On/Off 0 12.50V 12.31V
6 T+ 2.973V 2.973V 2.973V
7 T- 0 0 0
8 Ground 0 0 0

Green light was 1 sec On / 1 sec Off
Red Light continuously on

Obviously no charging happening.
allied
 
Posts: 10
Joined: Fri Feb 19, 2016 5:35 pm

Re: NS2 Troubleshooting

Postby Coulomb on Fri Apr 01, 2016 9:15 pm

The manual for the RED LED says the float setpoint is higher than absorption.
Coulomb
Site Admin
 
Posts: 1174
Joined: Sat Jun 06, 2009 5:11 pm

Re: NS2 Troubleshooting

Postby allied on Sat Apr 02, 2016 5:53 am

That is not the case. The absorption is set at 14.40 volts and the float is set at 13.60...per the manual.

This NS2 regulator was purchased on January 29, 2016 and installed a short time afterward. It has never worked properly. Is it under warranty? The voltage readings seem to change intermittently. Perhaps the regulator is faulty. My mechanic and I are very frustrated. I have spent a lot of money (and time) upgrading my electrical system, and have nothing to show for it.

Can you please send me a new NS2 and I will return the one I received in January?

John Frederick
713-882-0292
allied
 
Posts: 10
Joined: Fri Feb 19, 2016 5:35 pm

Re: NS2 Troubleshooting

Postby Coulomb on Sat Apr 02, 2016 6:20 pm

Ruth will send one out.
Coulomb
Site Admin
 
Posts: 1174
Joined: Sat Jun 06, 2009 5:11 pm

Re: NS2 Troubleshooting

Postby allied on Sat Apr 02, 2016 8:09 pm

Thank you very much.
allied
 
Posts: 10
Joined: Fri Feb 19, 2016 5:35 pm

Re: NS2 Troubleshooting

Postby allied on Tue Apr 05, 2016 4:20 pm

The boat originally was wired with 14 gage wire for the Next Step regulator. The NS2 diagram calls for 16 gage wire. Should I pigtail the 14 gage wire with 16 gage at the NS2 terminals? Or make do with the 14 gage?
allied
 
Posts: 10
Joined: Fri Feb 19, 2016 5:35 pm

Re: NS2 Troubleshooting

Postby allied on Sun Apr 17, 2016 11:19 am

After installing the new NS2 Regulator and confirming the wiring, I have two issues. I still get a Voltage Runaway error (red 6-3 sec) and I have no amber light. There is no voltage on the TB2-1 pin. With the engine running the alternator charges the house batteries, but not the engine battery.
The trouble shooting voltages are listed below.

1 B+ 13.7 13.0 12.93
2 Field 0 12.75 12.93
3 Alt. Grd. 0 0 0
4 House Bat. 13.9 13.02 13.00
5 On/Off 0 12.55 12.60
6 T+ 3.272 3.272 3.272
7 T- 0 0 0
8 Ground 0 0 0

As stated the red led was on 6 off 3, and the green was on 1 off 1.
allied
 
Posts: 10
Joined: Fri Feb 19, 2016 5:35 pm

Next

Return to NS2 Regulators

Who is online

Users browsing this forum: No registered users and 1 guest

cron