SC 10012 Not charging

For issue regarding AC operated battery chargers and Smart Charge Manager.

SC 10012 Not charging

Postby Patrick on Sat Jul 10, 2010 11:49 pm

Hello,

My previously brilliant Ample Power SC10012 battery charger has stopped charging. I noticed during my last visit to the boat that the batteries were down to half charged (and the charger was plugged in to shore power all winter). I switched the charger off and on again which usually starts a bulk charging cycle, but this time it appeared to deliver a brief float charge (14 volts or so at around 10 amps) for about 10 minutes, then switch off. I checked all connections I could see (not many of them) and then pulled out the unit, hoping to have it serviced. Does anyone have any advice on how to troubleshoot the charger? Is it possible to have this charger looked at by Ample Power, given that it is a bit "long in the tooth"/old?

Thanks for any assistance anyone can provide.....Patrick
Patrick
 
Posts: 1
Joined: Thu Jul 08, 2010 1:35 pm

Re: SC 10012 Not charging

Postby Coulomb on Mon Jul 12, 2010 11:18 am

It appears that the charger and SCM were working as expected. With deeply discharged batteries that are sulfated, battery voltage goes almost immediately to the absorption voltage and the SCM thinks the batteries are charged and truncates the absorption cycle.

You can lock the SCM into the ABS state and after several hours the batteries may accept charge again.

Prognosis for recovering the batteries is zero to grim.
Coulomb
Site Admin
 
Posts: 1174
Joined: Sat Jun 06, 2009 5:11 pm

Re: SC 10012 Not charging

Postby pldulin on Tue Jul 13, 2010 10:13 am

Thanks for a prompt reply.

This issue is now starting to make a little more sense. I think your diagnosis of my battery health may be accurate. I notice on my battery monitor that when everything wired to the batteries is turned off that I still have .2 amps leaving the battery (monitor still reads -.2 instead of 0), which has perplexed me. After disconnecting the charger, I also noticed that the batteries were all pretty low on water (top inch or so of plates were dry)....yes, that is grim and obviously negligent on my part. The batteries are also pretty old (around 8 years I believe). So I topped off the batteries and have had the boat out on the water a few times and my alternator in combination with solar panels seems to have brought the batteries back up to a decent level, but still I have the .2 amps leaving the battery with everything switched off.

A few questions....can I reasonalby conclude that my charger is working fine and that the initial problem was a combination of old batteries and low water levels in the battery?
Second, how do I lock the SCM into the ABS state on this model? I dont see any adjustments/switches except an on/off.

Thanks again for your help.
pldulin
 
Posts: 1
Joined: Sat Jul 10, 2010 11:31 pm

Re: SC 10012 Not charging

Postby Coulomb on Tue Jul 13, 2010 2:09 pm

With 8 years and dried out plates, the batteries are most certainly not worth much.

Don't trust the monitor. You may have a .2 draw, or the monitor might just be lying.
Coulomb
Site Admin
 
Posts: 1174
Joined: Sat Jun 06, 2009 5:11 pm


Return to AC Battery Chargers

Who is online

Users browsing this forum: No registered users and 1 guest

cron