Non-functioning PSC 45 and 55 Chargers

For issue regarding AC operated battery chargers and Smart Charge Manager.

Non-functioning PSC 45 and 55 Chargers

Postby shenandoah1 on Sun Aug 16, 2009 9:46 am

We have a PSC 45 and a PSC 55 that are not functioning - no 12 Volt or amperage output. These were ordered, installed and operated at different times over the past 2 - 5 years. We are using both a 45 and 55 amp PSC (one serves as a standby backback) to charge a bank of 3-130ah batteries for the 12 volt system on a Houseboat. The system also uses an Amplepower Smart Charger Manager and a BatMon to control battery charging and to monitor the system.

We are currently using a single functioning PSC 45, with no standby backup.

Prior to ordering a replacement PSC 55, we removed the end case cover to remove and check the output fuses (could not otherwise get fuses removed); then, to further observe any obvious damage we removed the top case cover.

The fuses were ok; however, we noted that both units have a pair of components (cylindrical - one of which is either labeled u45 or u55) of which one of each pair has the top expanded and fractured with a black powder substance visible.

From the information above can you advise it these chargers repairable? Also, would you be able to advise on why would the charger units (which were operated on the same 12 Volt system at different time periods) seem to fail in the same mode.

The 12 Volt house batteries, chargers, and monitoring system are configured and wired per a typical schematic that is published by Amplepower.

We have not performed the troubleshooting guide that is provided online for the SmartCharger Manager due to the houseboat being at a remote lake.

We can easily order the replacement charger; however, we would like advice on the seemly similar failure modes, and what we can do to lengthen the service of these chargers.

Thank you :?: :?
shenandoah1
 
Posts: 1
Joined: Sat Aug 15, 2009 2:35 pm

Re: Non-functioning PSC 45 and 55 Chargers

Postby Coulomb on Mon Aug 17, 2009 7:42 pm

The components are there to absorb transients. That both went, indicates you suffered a high voltage AC transient. That can happen when lightning strikes power lines, perhaps many miles away.

Generally the labor to repair those units is more than buying a new one.
Coulomb
Site Admin
 
Posts: 1174
Joined: Sat Jun 06, 2009 5:11 pm


Return to AC Battery Chargers

Who is online

Users browsing this forum: No registered users and 2 guests

cron