Parallel solenoid not being actuated

For issue regarding AC operated battery chargers and Smart Charge Manager.

Parallel solenoid not being actuated

Postby GeorgeB on Tue Jul 07, 2015 10:05 am

The parallel solenoid is not being actuated by the Smart Charge Manager. Charger Voltage is above 13 on Bat_1 but Bat_2 sits at 12 or 11.5 or wherever it was left after starting engines. Solenoid tests OK and has been replaced with spare with no change in results. The terminal 7 voltage reads 8.8 volts. If an external ground is touched to the solenoid it pulls in. And although it was just touched it remains pulled in, even when it should be separating them with B_1 <13 Volts. The charger is a Ample PSC 55-12 and is doing bulk, float etc properly.
I installed this system about 12 years ago and I believe it was working properly until recently. All is mounted in the engine room forward bulkhead on a Grand Banks 42. No corrosion on anything, it looks like it was installed yesterday.
What can it be? Can the Smart Charge Manager Fail in this manner. Am I missing checking something?
GeorgeB
 
Posts: 2
Joined: Mon Jul 06, 2015 11:23 am

Re: Parallel solenoid not being actuated

Postby Coulomb on Wed Jul 08, 2015 1:49 pm

It needs to be above 13V or increasing.


The Smart Charge Manager is not longer repairable.
Coulomb
Site Admin
 
Posts: 1174
Joined: Sat Jun 06, 2009 5:11 pm

Re: Parallel solenoid not being actuated

Postby GeorgeB on Wed Jul 08, 2015 7:35 pm

As i said B-1 IS above 13. I guess that you are answering my question as to whether it could fail in this way by saying that it is no longer repairable. What would be the best choice to replace the Smart Charge Manager?
GeorgeB
 
Posts: 2
Joined: Mon Jul 06, 2015 11:23 am


Return to AC Battery Chargers

Who is online

Users browsing this forum: No registered users and 2 guests

cron