Page 1 of 1

charger not working

PostPosted: Tue Jul 26, 2016 3:13 pm
by RussK
I purchased a PSC55-12 smart charger. I have a remote cabin with 12 volt lighting. When i installed the new charger it didn't charge and I have been unable to make it work. We supply 110V power to the charger with a generator. I'm not sure if it is wired wrong or defective. How do I test the charger?
RussK

Re: charger not working

PostPosted: Tue Jul 26, 2016 7:03 pm
by Coulomb
Disconnect the charger from the batteries. Apply AC to the unit. You should measure 13-14 Volts on the output.

If it works that way then you'll have to look further. What size is the generator?

Re: charger not working

PostPosted: Wed Jul 27, 2016 7:05 am
by RussK
We are using 2 Honda 2000kw generators coupled together. As soon as I can get someone out to the cabin, i will check the voltage. Thanks RussK

Re: charger not working

PostPosted: Thu Jul 28, 2016 9:20 am
by RussK
We brought the charger to town.
Plug it in: no voltage at all.
City power or genset.

Re: charger not working

PostPosted: Thu Jul 28, 2016 11:18 am
by Coulomb
There are a couple automotive style fuses in the back of the unit that you could check.

When and from whom did you buy the charger?

Re: charger not working

PostPosted: Sun Aug 14, 2016 1:12 pm
by RussK
Fuses seem good. We purchased it from AmplePower.com in April of this year.
RussK

Re: charger not working

PostPosted: Mon Aug 15, 2016 11:49 am
by Coulomb
Please contact Ruth for a replacement.