Page 1 of 1

Overheating

PostPosted: Sat Aug 07, 2010 10:06 pm
by dogbark
I have an overheat cutout after 15 minutes of charging on a marine DBC, Genie 150. Raw water discharge seems normal, belt tension on raw water pump seems good and impeller is good. Coolant level is normal. Is there a thermostat on the fresh water side? Location? Thanks.

Re: Overheating

PostPosted: Mon Aug 09, 2010 10:46 am
by Coulomb
Wow, that unit is OLD. Engine driven water pumps on Genies went out about 1990.

Have you read the Cooling Guide here: http://www.amplepower.com/wire/cooling/index.html ?

Re: Overheating

PostPosted: Fri Aug 13, 2010 10:07 am
by dogbark
Checked all the items in the cooling guide. Yes, unit is old, but it has been reliable since install in late 80's until now. Raw water pump and exhaust elbow are one year old and strainer is clear. My question is about a fresh water thermostat as part of the Kubota cooling system/Ample power heat exchanger. Thanks

Re: Overheating

PostPosted: Fri Aug 13, 2010 10:21 am
by Coulomb
There is no thermostat in the system. Cooling is done by thermo-siphon principles for the coolant and the design of the heat exchanger versus the amount of raw water pumped.

Is the exhaust insulated?

Re: Overheating

PostPosted: Sun Aug 15, 2010 11:17 am
by dogbark
Exhaust elbow is not insulated. Is heat transfer the issue? How about blockage internal to heat exchanger after all these years? Thanks

Re: Overheating

PostPosted: Sun Aug 15, 2010 6:38 pm
by Coulomb
There could be blockage, but you said that exhaust water flow was normal, so I ruled that out.

Insulating the header/exhaust is pretty much mandatory, unless the unit is operating in ambient air.

You may need to back off the alternator output current to keep it cool enough.

Re: Overheating

PostPosted: Sun Aug 15, 2010 7:13 pm
by dogbark
Well it is operating in ambient air but I will try both insulating the exhaust pipe and turning down the alternator output but it has worked fine for twenty years previously so I was thinking something internal must have changed. Thanks for the suggestions.