genie 150/12v surging at start-up

For issue regarding Ample Power diesel/bio-diesel battery chargers.

genie 150/12v surging at start-up

Postby Katmai on Tue May 05, 2015 6:26 pm

My Genie 150/12v engine is surging at start-up. The engine surges for a couple of minutes following engine start-up, with alternator remaining in the off position. The surging of the Kubota engine goes from near stop, to full stop, to full rpm, very random, and is not temperature sensitive. It happens wether the engine is hot or cold, but only at engine start-up for what seems a couple of minutes. Once the engine is running it runs great, no surging, full power. I have change fuel filters, Racor 2mc mesh, no change. Is there some experience with this behavior in the forum, Columbo? Any ideas or help is appreciated.
Katmai
 
Posts: 24
Joined: Tue Sep 21, 2010 1:54 am

Re: genie 150/12v surging at start-up

Postby Coulomb on Tue May 05, 2015 7:39 pm

Air in the fuel line?
Coulomb
Site Admin
 
Posts: 1174
Joined: Sat Jun 06, 2009 5:11 pm

Re: genie 150/12v surging at start-up

Postby Katmai on Tue May 05, 2015 10:31 pm

It seems like a fuel starvation thing. Then on the other hand Genie runs fine and reliably every time after a minute or two of running. I see no air in the Racor filter and then why only at start up? I have already gone through and tightened hose clamps, supply line fittings, etc. the surging starts immediately following start-up. If air in the fuel line, then that would indicate the air bubbles are very close to the injection pump and a ways down the fuel supply system.

Once Genie run and runs well and it does run well, if I shut it off to a full stop for even a split second and restart then same surging scenario repeats. This makes me think it is not air in the fuel supply between the tank to the solenoid. Could the solenoid develope an air leak at the high suction moment during shut down?
Katmai
 
Posts: 24
Joined: Tue Sep 21, 2010 1:54 am

Re: genie 150/12v surging at start-up

Postby Coulomb on Wed May 06, 2015 10:01 am

If you ran the fuel pump a little before starting does that change the surging?

The system can be fully bled unless the activate the fuel solenoid and then run the fuel pump.
Coulomb
Site Admin
 
Posts: 1174
Joined: Sat Jun 06, 2009 5:11 pm

Re: genie 150/12v surging at start-up

Postby Katmai on Thu May 07, 2015 7:00 pm

Thanks Columb. Problem solved! We now have only 31 hrs on the Genie. The problem was the fuel pump. The pump originally supplied was a Walbro FRD-2, I noticed the spare I bought from you is a Walbro FRB-13, a much more powerful pump that dry lifts to 48" and supplies 43 gph instead the 24" and 10 gph of the WRD-2 pump. I exchanged pumps and all is well. The behavior we had was that the original pump could just supply bit more fuel to recharge the fuel consumed after the solenoid shut and run the engine at the same time. This initial lack of fuel caused the surging until the fuel line was again fully pressurized, a minute or so later.
Eric
Katmai
 
Posts: 24
Joined: Tue Sep 21, 2010 1:54 am

Re: genie 150/12v surging at start-up

Postby Coulomb on Fri May 08, 2015 11:19 am

Let's hope that solves the problem.
Coulomb
Site Admin
 
Posts: 1174
Joined: Sat Jun 06, 2009 5:11 pm

Re: genie 150/12v surging at start-up

Postby Katmai on Fri Jul 31, 2015 4:00 pm

Coulomb, I can report back with confidence that the bigger fuel pump solved the problem.
Eric
Katmai
 
Posts: 24
Joined: Tue Sep 21, 2010 1:54 am

Re: genie 150/12v surging at start-up

Postby Coulomb on Fri Jul 31, 2015 5:19 pm

Thanks, that's good to know.
Coulomb
Site Admin
 
Posts: 1174
Joined: Sat Jun 06, 2009 5:11 pm


Return to Ample Power Diesel Battery Chargers

Who is online

Users browsing this forum: No registered users and 1 guest

cron