V3 regulator switching to float way to early

For all issues involving the Smart Alternator Regulators, V1, V2 and V3

V3 regulator switching to float way to early

Postby Merle on Tue May 06, 2014 4:20 pm

Hello,I have been troubleshooting a smart regulator and ample alternator pairing on a Perkins Marine engine. There are lifeline agm's attached that are a year old. The alternator output is normal at 150 amps under bulk mode but the trouble is that the regulator switches to gas charge very quickly ( one minute) and after a short 20 minutes is into absorb mode where it still produces 125 amps. Within 15 minutes more the regulator switches into float mode and begins to taper the current as expected drastically increasing charging times for the battery bank. The voltage at which the regulator is charging (in gas and absorb) is held at 15.05 volts which seems a bit high considering the temp sensor is at 3.05 volts and the batteries are at 40% discharge on a 800 ah bank. Two questions, why the high charge voltage (can the agm's handle this) and is it possible that the battery conditions (sulfation) is causing the early switching to low current charge mode as voltage values are met too early.

Thanks for your help
Merle
 
Posts: 1
Joined: Wed Jan 29, 2014 4:28 pm

Re: V3 regulator switching to float way to early

Postby Coulomb on Wed May 07, 2014 11:16 am

You don't say how you're determining that the batteries are at 40% state of charge. At that level good batteries would be able to accept the current without the voltage rise that you report.

A. The 40% is in error.
B. Or, batteries are not good.
Coulomb
Site Admin
 
Posts: 1174
Joined: Sat Jun 06, 2009 5:11 pm


Return to Smart Alternator Regulators

Who is online

Users browsing this forum: No registered users and 1 guest

cron