Next 12p error condition after being sent in for repair

For Next Step Regulators including Lifeline units. Use the NS2 forum for NS2 issues.

Next 12p error condition after being sent in for repair

Postby JOHN3534 on Tue Sep 29, 2009 12:20 pm

Hi,

I recently sent my Next 12p in for repair. After re-installing, the green indicator light shows "bulk charge" with 2 on 1 off. However, the red indicator light shows "No battery sense" with flashing 3 on 1 off. I have checked all of the voltages and find that there is 12.4v being supplied to the wire connected to the battery sense lead. I have reset all the wires to be sure they are properly seated and have re-tested now three times.

Is there something I can do here or does the unit need to be returned again?


Jeff Johnson

PS Making me login to a BBS to post this problem in hopes of a result is unsatisfactory customer service.
JOHN3534
 
Posts: 1
Joined: Mon Sep 28, 2009 1:47 pm

Re: Next 12p error condition after being sent in for repair

Postby Coulomb on Wed Sep 30, 2009 2:06 pm

The problem that was repaired on the Next Step Regulator was a blown up circuit on the battery sense line. This type of failure is generally caused by a high voltage transient on the sense line.

Do you have a battery selector switch. They can create the high voltage transient if turned off when the engine is running. They can also spontaneously open. See this URL: http://www.amplepower.com/apps/burnt_sw/index.html.

Send the unit back and we'll see if the failure mode is the same.
Coulomb
Site Admin
 
Posts: 1174
Joined: Sat Jun 06, 2009 5:11 pm


Return to Next Step Regulators

Who is online

Users browsing this forum: No registered users and 1 guest

cron